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Learn About The Blue Mango Learning 
Systems Documentation Methodology 

Docs that Rock 
We take a very simple and pragmatic approach to creating, using and updating documentation. 
We use this methodology for creating: 

• Customer support documentation 
• Process documentation 

The methodology is very easy to follow and delivers instant results by increasing the efficiency 
of your organization. 

We have created a mini site that contains articles and videos outlining our approach to creating, 
using and maintaining documentation. You can find it here: 

http://docs.bluemangolearning.com 

Additional Information on ScreenSteps & ScreenSteps Live 
To learn more about the Blue Mango Learning Systems methodology for customer support and 
how to implement ScreenSteps in your organization we invite you to browse some additional 
resources which include articles, ebooks and webinars: 

http://www.bluemangolearning.com/customer_support/ 
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Creating a Lesson 

Learn how to create a lesson using ScreenSteps 2. 

Select New Lesson 

To create a new Lesson, click on the New Lesson button. 

Edit Lesson Title 

A new lesson will be created and opened for editing. Click on the lesson title to edit it. 
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Capture Images/Create Steps 

There are several ways to create new steps: 

1. Click the Step button - this creates a blank step. 
2. Click the Capture button to capture a screenshot and create a new step. You can also open 

the Capture Palette by clicking on the arrow next to the camera. 
3. Turn on the Clipboard Recorder. Any image you place on the system clipboard will be 

added to your ScreenSteps lesson. 
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Add Some Text 

Here you can see that I have captured an image. A step has been created. You can add a step 
title (1) and/or step instructions (2). Just click on the fields to edit them. 
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Annotate Images 

Select an image by clicking on it. 

You will see the image annotation tools appear in the toolbar. Select the tool you want to use 
and draw on the image. 

Adjust Annotations 

Open the Inspector palette to adjust the color, thickness and other annotation parameters. 
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Here I have used the rectangle tool. 

Saving and Other Stuff 

Don't worry about saving. All of your changes are saved as you make them. Some additional 
things you might want to do are: 

1. Export the lesson to HTML, PDF, to your own blog/wiki, Word (Pro only) or to ScreenSteps 
Live. 

2. Share the lesson using Clarify-it.com or by copying it to the system clipboard as HTML or 
PDF. 

3. Add tags 
4. Enter a description for the lesson 
5. Go back to the Lesson Library (that is where you can see all of the lessons you have created) 
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Key ScreenSteps Concepts 

This lesson will introduce some key ScreenSteps concepts to you.  Understanding these 
terms will help you get the most out of ScreenSteps.  ScreenSteps is a somewhat 
"opinionated" application.  It really is designed for doing a very different type of 
documentation than what you may be used to.  While you can use ScreenSteps any way 
that you would like, following the tips in this lesson will make your lessons more readable 
and easier to update in the future. 

The Library 

All lessons in ScreenSteps are stored in a Library file.  A library is just a collection of ScreenSteps 
lessons.  There is no organization to it.  You can't output a PDF or HTML version of your entire 
library.  All it does is automatically save your lessons so that you don't have to decide where to 
save them on your hard drive.  You can create as many libraries as you would like or just one. 
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A Lesson 

A Lesson is a single document in ScreenSteps.  It can be exported to any format that 
ScreenSteps supports, such as HTML, PDF or ScreenSteps Live. 

A typical lesson should be between 3 and 20 steps.  Occasionally you might write a lesson that 
is longer than this, but that should be the exception, not the rule.  Lessons that are longer 
become laborious to read as well as update.  

Most ScreenSteps lessons should focus around completing a single task. An example might be 
“Adding a Table of Contents”.  The more focused the title the better the resulting lesson. 
 Lessons such as “Configuring Application Preferences” generally become tougher to write in 
ScreenSteps because they are somewhat vague.  ScreenSteps works much better if you are 
creating a lesson titled “Setting The Default Output Folder in Preferences”.  The action is more 
concrete and lends itself to a step by step guide approach which is exactly what a ScreenSteps 
lesson is geared for. 

By focusing on a task based approach to your documentation you will find a few things: 

1. You will write many more lessons. 
2. Your lessons will be much shorter. 
3. Your lessons will be much easier to write. 
4. Your lessons will be much easier to update. 
5. Your lessons will be much easier to read. 
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Tags 

Tags are simply a tool for organizing and finding your lessons in your library.  You can't export a 
tag as a PDF or HTML file.  Think of tags as basically categories for lessons that you create.  A 
lesson can have as many tags as you would like.  

You must be in "Tags Mode" (1) to view a list of the tags in your program.  As you add tags to 
your lesson they will show up in the Tags list (2). 
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Manuals 

Manuals are created from multiple ScreenSteps lessons.  Use a Manual to organize all of your 
(hopefully short) ScreenSteps lessons and then export them as a PDF, HTML or Word files 
complete with a table of contents (manual export is only available in ScreenSteps Pro). Manuals 
can also be exported to ScreenSteps Live. 

You must be in "Manuals mode" (1) to view manuals that you have created (2).  When you select 
a Manual, it is displayed on the right (3). 
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Anatomy of a Manual 

A Manual contains two types of elements, Chapters (1) and Lessons (2). 

Chapters are just groupings of lessons.  Nothing more.  You can give a chapter a title but that is 
it.  The chapter title will be displayed in the table of contents.  

Lessons are just the lessons from your library that you have added to the manual.  To add a 
lesson to a manual it must be in your library. 

Packages 
The final concept for this lesson is that of a Package.  A package is simply a means of moving 
ScreenSteps lessons and manuals between libraries or backing up a lesson or manual to a 
single file.  You can export a single lesson or a full manual (pro only) as a package.  Packages are 
the method you should use to share ScreenSteps lessons with other users of ScreenSteps if you 
want them to be able to edit those lessons. 
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Display Overview 

This lesson gives a brief overview of the ScreenSteps 2 display. 

Main Screen 

The main screen is divided into four areas: 

1. Toolbar 
2. Search 
3. Library and Tags List 
4. Lessons List 

Selecting a Tag from the left (3) will display the lessons for that Tag to the right (4). 

Note: The tags (3) will only appear if you have tagged a lesson.  When you first launch 
ScreenSteps this list will be empty. 
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Modes 

Two view modes are possible, Tags and Manuals.  Manuals you create by manually dragging 
lessons into an outline.  Tag listings are automatically created as you tag lessons. 

Tags 

The tags view will list all of the tags that you have added to lessons you have created.  The 
number of lessons in the tag are shown to the right. 

You can also drag lessons from the list onto a tag to add that tag to a lesson. 
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Manual Display 

If you have a manual selected (1) you will see the chapters (2) and lessons (3) for that manual to 
the right.  Chapters are just a way of organizing lessons inside of a manual. 
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Viewing a Lesson 

By clicking on a lesson you will open the lesson for editing/viewing.  The screen is divided as 
follows: 

1. Lesson title 
2. Lesson description 
3. Lesson steps 

Lesson Steps 
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The Steps are setup as follows: 

1. Step Title 
2. Step Instructions 
3. Image 
4. Image Tools 
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How ScreenSteps Deals With Large Images 

ScreenSteps provides a couple of settings that can help in working with large images. 

Scaling Images While Authoring 

When you work with ScreenSteps you will notice that after you capture an image it appears to 
be smaller within ScreenSteps than it was when you capture it. Because the content are of the 
formats you export to are often smaller than the screenshots you take, ScreenSteps can scale 
your screenshots to fit within a predefined width while authoring. By doing this, your annotated 
image will not need to be scaled when exporting. This results in crisper annotations. 

The percentage that an image is scaled by appears right below the image in the authoring 
environment (1). 

You can change the percentage at any time by clicking on the arrow next to the percentage. 
This will display the menu of options for scaling (2). For more information about this menu 
please see this lesson. 

Note: ScreenSteps will always store the original image you capture. Scaling only occurs while 
authoring and exporting. 
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How ScreenSteps Determines How to Scale Images You 
Capture 

ScreenSteps has preference settings that allow you  to automatically scale all images you 
capture to a specific width and height. By default, ScreenSteps will scale all images that are over 
560 pixels wide. If you prefer to always have your images appear at 100% of their actual size 
then you can uncheck the checkbox for the "Scale Images on Capture" preference. 

Scaling Images When Exporting 

ScreenSteps may also scale your images when it comes time to export. 

For PDF output an image will be scaled if it is too wide to fit in the available width. The height is 
sometimes scaled to make the image fit on the page as well. 
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For Word output, the full image is included and the editor you use to view the document will 
provide any necessary scaling. 

When using an HTML template to export, the Maximum Image Width setting for the template 
you export with is used. As you can see in this picture, the maximum image width for this 
template is 560 pixels. If you have any images in your lesson that are wider than 560 pixels then 
they will be scaled to fit within 560 pixels. An HTML template can specify that the full-size image 
should be included as well. In this case ScreenSteps will also include the full size version so that 
the user can click on a link to view it. 

So why does ScreenSteps allow you to scale images during authoring and exporting? The 
reason is that if you scale an image during export then the image annotations will be scaled as 
well. The annotations will not be as large as they appear in the ScreenSteps editor and scaling 
can result in annotations that are not as crisp as they would otherwise be if they had not been 
scaled. 
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Registering ScreenSteps With a Serial 
Number 

Open Registration Dialog 

To open the registration dialog select the Help > Register ScreenSteps menu item. 

Enter Serial Number 

Enter your serial number in the Serial # field (1). The Register button will activate when you 
have entered a valid serial number. 
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After clicking the Register button a thank you dialog will be displayed (1) and the license type 
will appear below the serial number (2). 

Note On Upgrades 

If you are upgrading from ScreenSteps version 1 to ScreenSteps version 2 then an Upgrade 
Serial Number dialog will appear after clicking Register (1). You will need to enter your version 
1 serial number in the provided field (2) and click Register (3) in the Upgrade Serial Number 
window to complete the registration. 
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Registering ScreenSteps With a ScreenSteps 
Live Account 

If you have a ScreenSteps Live account that includes desktop licenses then use the 
following steps to register your software. 

Open Registration Dialog 

To open the registration dialog select the Help > Register ScreenSteps menu item. 
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Select ScreenSteps Live Account and Enter Information 

Select the ScreenSteps Live tab (1). Enter your ScreenSteps account information (2) and then 
select Register (3). 

NOTE: Registering your software using a ScreenSteps Live account will automatically create a 
Web Export account with your ScreenSteps Live information if one does not already exist. 
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Upgrading from ScreenSteps 1 to 
ScreenSteps 2 Pro or Standard 

This lesson will show you how to upgrade from ScreenSteps 1 to ScreenSteps 2 Pro. 

Get Upgrade Key 
If you already have an upgrade serial key then skip down to the "Register ScreenSteps" step in 
this lesson.  If you don't have an upgrade serial number yet then you will need to purchase one 
through the upgrade store. 

Visit the Upgrade Store 

You can click on the Upgrade Store link from our purchase page or just go here. 
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Select Upgrade Type 

Select the upgrade you would like to purchase.  Make sure that you purchase an upgrade from 
ScreenSteps 1.x if you have a 1.x license key. 

Register ScreenSteps 

Once you have an upgrade serial number you are ready to register ScreenSteps. Select Register 
ScreenSteps from the Help menu. 
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Enter Your New Registration Key 

Enter the serial # that you just purchased for either the ScreenSteps 2 Standard or Pro upgrade. 

Select Register. 

Enter ScreenSteps 1 Serial # 
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You will be asked to enter your ScreenSteps 1 serial number.  Do that and click on Register. 
You will see a dialog confirming that registration was successful. 

Be sure to keep both your ScreenSteps 1 and ScreenSteps 2 serial keys in a safe place in case 
you need to install ScreenSteps on another system someday. 
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Capturing Images 
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Capturing Images Using the Global Key 
Command 

As of version 2.8.7 you can assign a global key command to capture images into 
ScreenSteps on both Mac OS X and Windows. 

Open Preferences 

Set a Hot Key 
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Enter the key you would like to use as the hot key and check off any modifiers you would like to 
use.  On OS X the default settings are command + shift + 2. On Windows the default settings 
are control + shift + 2. 

Capture To Your Heart's Content 
Now, if you have ScreenSteps open you can hold down your key command (command + shift + 
2 in my case) and the image will automatically be captured into ScreenSteps.  If you don't have a 
lesson loaded a new lesson will be created for you. 
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Using the Capture Tool 

ScreenSteps 2.8.7 introduced a brand new capture tool that helps streamline capturing new 
images and replacing existing images. The same features are provided on both Windows 
and Mac OS X. 

Capture Feedback 

The Capture Feedback window provides information about the current capture session and 
spells out the shortcut keys you can use to access certain features. 

1. The space bar toggles between window capture and area capture mode. In this screenshot 
window capture mode is active. 

2. Pressing the R key cycles through your capture history. As you press R, previous rectangles 
that you have capture will appear. Hold down the Shift key while pressing R to cycle 
backwards. 

3. Press the C key to toggle the visibility of the mouse cursor. By default the mouse cursor will 
be hidden but ScreenSteps will remember the last setting you used each time a new screen 
capture session begins. 
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Capturing Windows 

In window capture mode the window under the capture cursor will highlight (1). Clicking or 
pressing the enter/return key will capture that window. 

You know you are in window capture mode when the window icon is visible (2). 

Tip: You can switch to area capture mode by clicking and dragging the mouse. ScreenSteps will 
automatically exit window capture mode and begin drawing a capture rectangle. 
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Area Capture Mode 

In area capture mode you manually define the are of the screen that you want to capture (1). 
Simply click and drag to draw a capture rectangle. You can then use the handles around the 
rectangle to resize as needed (2). 

You can nudge the rectangle around the screen a pixel at a time using the arrow keys. Hold 
down the SHIFT key to nudge the rectangle 10 pixels at a time. 

To capture the area, press the enter/return key or click on the camera icon (3). 
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Showing and Hiding the Cursor 

You can specify whether or not you want the cursor to appear in your screenshot by pressing 
the C key. In this screenshot you can see that the cursor is visible. 

Here is the same screenshot with the cursor hidden. 
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Using the Capture Tool Delay 

Shows you how to use the capture tool. 

Select a Delay 

Select a delay setting.  You should only need to use a delay setting if you need to capture a 
menu or need to otherwise set up the screenshot.  If not, Instant Capture should work fine. 

Select Capture 

Select Capture.  The ScreenSteps window will disappear.  If you set a delay the counter will start. 
 As soon as your cursor turns into a cross-hair you can capture your image. 
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Important Note For OS X Users 

If you want to capture the Apple Menu you will need to switch to another application (e.g. the 
Finder) after clicking on the Capture Tool. If you don't then the ScreenSteps' countdown timer 
will pause while the Apple Menu is active and the screen capture cross-hairs will never become 
active. 
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Using the Capture Palette 

Learn how to use the Capture Palette in ScreenSteps to quickly get screen shots.  The 
Capture Palette can float on top of other applications while you work.  Just click the capture 
icon to capture an image and add it to a ScreenSteps lesson. 

Open Capture Palette 

Select Window > Show Capture Palette. 

Capture Images 

You can now hide the main ScreenSteps window.  The Capture Palette will float on top of your 
other windows allowing you to grab images while you are working in your other applications. 
 Once you are done, return to the ScreenSteps main window.  All your images will be ready and 
waiting for you. 
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How to Update Images in a Lesson 

One of the most painful parts about using screenshots in your documentation is having to 
update them when an application changes its user interface. ScreenSteps makes the 
process super simple. 

Click "Replace Image" 

Just go to the step with the image you want to replace and click the Replace Image icon. Here is 
what will happen: 

1. ScreenSteps will have remembered the exact size and location of the original capture on 
your monitor and will open a capture regions with those dimensions. You can reposition or 
resize the capture window based on your needs. 

2. After you hit return to capture the image the image will be replaced in your lesson. But the 
annotations (arrows, boxes, ovals, etc.) will not replaced. You can just reposition you 
annotations on the updated screenshot. 

You never have to redraw all of your annotations from scratch. This will save you literally hours 
when updating a large manual. 
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Using the Clipboard Recorder 

Learn how to use the Clipboard Recorder.  The Clipboard Recorder will add any image that 
is copied to the system clipboard as a ScreenSteps step. The system clipboard is where data 
applications store data when you use the Edit > Copy and Edit > Cut menus. 

What is the Clipboard Recorder? 

The Clipboard recorder automatically inserts images that have been placed on the system 
clipboard by a 3rd party application into ScreenSteps. The 3rd party application might be be 
another screen capture utility, a QuickTime video, or another graphics application. 

To activate the Clipboard Recorder just click on it. 

Once the Clipboard Reorder is turned on, each time another application copies an image to the 
clipboard ScreenSteps will create a new step and import the image. 

This is what the Clipboard Recorder will look like when it is active. While the clipboard recorder 
is turned on ScreenSteps will create a new step every time an application places an image in a 
format that ScreenSteps supports on the system clipboard. 

Click on it again to deactivate it. 
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Importing Images Into a Step 

This lesson will show you how to import images that you already have saved on your hard 
drive into a step. 

Option 1: Drag & Drop 

You can drag and drop files from your file system onto a step in ScreenSteps. When you drag an 
image over the step title, instructions or existing image a prompt will appear telling you that the 
image will be attached to the step. 
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Option 2: Use the Menu or Contextual Menu 

You can also add an image to a step using the Lesson menu or the step contextual menu. 

Begin by creating a new step by clicking on the Step button. 

Select Step 
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Select Import Image File 

Select Lesson > Step Image > Import Image File.  Select your image from the file browser and 
it will be imported into your step. 

Or you can right-click on the step and select Import Image File... from the contextual menu. 
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How to Capture a Menu 

There are a variety of ways you can capture menu items. This is one solution that will work 
on Mac or Windows. 

Open the Capture Palette 

Go to Application 

Go to the application that has the menu you want to capture. Make sure the capture palette has 
a delay set (1). Then click the capture icon (2). 
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Open Menu 

The countdown will start. Click on the menu you want to capture. IMPORTANT - Don't click and 
hold the mouse. Click once to activate the menu and release. 

Leave the menu open until the countdown expires and then just drag the capture region over 
the area you want to capture. The key is to not hold down the mouse button when you are opening 
the menu. 
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Important Note For OS X Users 

If you want to capture the Apple Menu you will need to switch to another application (e.g. the 
Finder) after clicking on the Capture Tool. If you don't then the ScreenSteps' countdown timer 
will pause while the Apple Menu is active and the screen capture cross-hairs will never become 
active. 
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Using SnagIt with ScreenSteps 

Learn how to set SnagIt to output to the system clipboard.  You can then turn on the 
Clipboard Recorder in ScreenSteps and use SnagIt to capture images for your ScreenSteps 
lessons. 

Select Your Profile 

Open SnagIt and select the profile you would like to use. 
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Set Output to Clipboard 

Set the Output setting to Clipboard. 

Turn On Clipboard Recorder in ScreenSteps 

Create a new lesson in ScreenSteps and turn on the Clipboard Recorder.  Now, any image you 
capture with SnagIt will be added to your ScreenSteps lesson. 
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Dragging and Dropping Images Onto Lessons 

This lesson will show you how to drag single or multiple images onto a lesson.  This can be 
a quick way to create steps if you already have existing images you would like to use. 

Drag a Single Image 

Drag a single image into the lesson area and a new step will be created with that image. 
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Here the step has been created. 

Drag Multiple Images 

Dragging multiple images into the lesson area will create multiple steps. 
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The images will be inserted in the order they appear after sorting by file name. 

Replace an Image 

Drag an image onto an image in an existing step to replace it. 
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Embedding Video in a Step 

This lesson will show you how to embed video that has been posted to a video sharing 
service such as YouTube into a step. Video that is embedded will only be available in blog, 
html or ScreenSteps Live export formats. For PDF and Word export you can set a url that 
will link to the video online. 

Choose Step 
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Select Set Video Embed Code 

Right click on the image or step and select Set Video Embed Code... 

Enter Information 
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Enter the embed code (1). For HTML, ScreenSteps Live and blog export this information will 
replace the image on the screen. 

Optional: Enter a url to be used for PDF and Word export (2) 

Movie Icon Appears 

You will now see a movie icon appear next to the step image. You can click on this to edit the 
embed code. 

Embed Code Without Image 

If you have embed code present, but no image then you will see the movie icon in the image 
area. Click on the movie icon to edit the embed code. 
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Example of HTML Output 

PDF Example 
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In the PDF version the image has a url attached to it. Clicking on the image will open the url in 
the users browser. 
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Editing Steps 
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Formatting Text 

Learn what text editing options are available in ScreenSteps 2. 

Text Formatting Tools 

If you open a text field in a lesson for step instructions (1) or lesson description (2) the text 
editing tools will appear on the toolbar (3).  Text editing tools are not available for lesson titles 
or step titles. 

The tools are all pretty self-explanatory.  Select some text and click on a tool to apply the 
formatting. 
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Using The Format Menu 

Alternatively you can use the Format menu to format text. This menu also displays the shortcut 
keys for each formatting option. 
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Insert a Link to a Web Page Into Your Lesson 

Select Text 

To insert a URL begin by selecting the text you would like create the link from. 

Click On Link Button 

Insert URL 

From the URL tab (1) type the url you would like to link to (2). You can specify whether or not 
the link should open in a new window by checking the Open link in a new window checkbox. 

Note: The Manual Lesson tab will only be active if you are editing a lesson in a manual. 
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Previewing the URL 

If you hover the cursor over the link the url will appear as a tool tip.  If you hold down "alt" on 
Windows or "command" on Mac when you click on the link, it will be opened in your default 
web browser. 

Page 66ScreenSteps 2.9



Insert a Link to Another Lesson in the Same 
Manual 

This lesson will show you how to link from one lesson in a manual to another lesson in the 
same manual. 

Open a Lesson in a Manual 

You can only link between lessons that are in the same manual. 

Select Text 

Select the text that you would like to link from. 
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Click On Link Button 

Select Lesson 

In the Link dialog that opens select the Manual Lesson tab (1). 

Next, select on the lesson you would like to link to (2) and click OK. 

The text will now link to that lesson. If you hover over the text then the name of the lesson the 
text links to will appear as a tooltip. 

If you CMD + click the link on Mac, or ALT + click the link on Windows while editing the manual 
lesson then the lesson the text links to will be opened for editing. 
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Removing a link from your text 

Follow these directions to remove a link from your text in ScreenSteps. 

Find Text 

Above is some text with a link that I want to remove. 
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Select Text and Plain 

1. Select the text. 
2. Select Plain. 

The url will be removed. 
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Annotating Images 

Learn how to use the annotations tools built into ScreenSteps. 

Annotating Images 

When you select an image (1) the annotation tools will appear on the toolbar (2).  The current 
tools are Line, Rectangle, Oval, Sequence, Text and Blur. 
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Make an Annotation 

Just select a tool and draw on the image.  In this example we have used the rectangle tool. 

Editing Tools 

1. Select - use the Select tool to select, resize and delete annotations. Quick Tip: Press "s" to 
select this tool. 

2. Crop - use this to crop images. Quick Tip: Press "c" to select this tool. 

Annotations 

These five tools allow you to annotate images: 

1. Line - draw straight lines with or without arrows. 
2. Rectangle - draw rectangles with or without fills. 
3. Oval - draw ovals with or without fills. 
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4. Sequence - add numbers to your image. 
5. Text - add text annotations to your image. 
6. Blur - obfuscate sensitive information such as login names and passwords. 

Quick Tip: Press "a" to select in tool in turn. Hold down the "shift" key to select in reverse order. 

Inspector 

Open the Inspector to adjust colors, line thickness and fill as well as other parameters. 

You can update multiple annotations on the same step by clicking on the "Apply to All" buttons 
for the current annotation.  This will update all annotations for the current Step or the entire 
Lesson depending on which option you select. 
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Using the Blur Tool 

Select Image and Blur Tool 

Click and drag over the area you want to blur 

Click and drag over the area you want to blur. You can resize your blur box to cover the exact 
area you want to hide. 

Page 74ScreenSteps 2.9



Adjust Blur Amount 

Double click on the blur in your image to open the Blur Annotation Inspector. Here you can 
adjust the slider to change the amount of blur that is applied. 

Removing a Blur Annotation 

To remove a blur annotation simple select the blurred area on your image (you will see boxes 
around the blur rectangle) and press delete. 
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Cropping Images 

This lesson will show you how to crop images in ScreenSteps. 

Select the Image You Wish to Crop 

Click on the image you want to crop. 

Select Crop Tool 
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Position Cursor 

Position the cursor where you would like to begin your crop and click and hold. 
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Drag 

Drag over the area that you want to crop. 

Press Return 

Press return on your keyboard.  The image will be cropped. 
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Optional: Resize 

If you would like to resize the image after cropping, then just select the new size from the drop-
down on the right. This affects the size the image will be exported at. It does not resize the 
actual image on disk. 
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Image Tools 

Learn what those icons are next to images in ScreenSteps. 

Image Tools 

There are four tools attached to each image in ScreenSteps 2: 

1. Replace Image - click this icon to capture an image and insert it into the current step.  The 
current image will be removed but the annotations will stay in place.  This is a great tool for 
when you need to update documentation for a new interface. 

2. Export to Clipboard - copies the image along with annotations to the clipboard ready to be 
pasted into another application. 

3. Export to File - exports the images with annotations to a file. 
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Resize Image 

At the bottom of each step image a percentage is displayed (1). This percentage represents the 
working size of the step image. The working size is the size that is displayed in ScreenSteps and 
that will be used when you export*. For example, if you capture a screenshot of your software 
that is 800 x 600 pixels you may only want to export the image at 400 x 300 pixels. By selecting 
50% from the drop-down menu the image would display at 400 x 300 pixels in ScreenSteps and 
would also be output at this size. 

If you need to quickly resize your image so that it is as large as possible while still fitting within 
the maximum dimensions you've defined in your preferences then select Scale to Fit 
Constraints In Preferences (2). 

To modify the output dimensions of a step image click on the triangle (3) and make a selection 
from the menu that appears. 

*Note: Images will sometimes be downsized if they cannot fit within the maximum width or 
height allowable for the export option chosen. When exporting to HTML (as of version 2.0.3) or 
ScreenSteps Live the downsized image will be displayed in the lesson and a Zoom link will 
appear which will open the full-size image in a new window. 
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Viewing Image Dimensions 

If you place the mouse cursor over the image resize control a tooltip will appear showing the 
original image dimensions and the dimensions you have set for output. 

Scaling Annotations 

When you resize an image you may or may not want to scale the annotations as well. For 
example, if you are updating a screenshot you most likely do not want to scale the annotations, 
you just want to reposition them after the updated screenshot is inserted. To toggle whether or 
not annotations are scaled when resizing an image just select Scale Annotations from the 
menu. 
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Resizing Using Custom Values 

The resize menu provides some default percentages that you can use to resize your image. If 
you need more control over the dimensions select "Custom Value" from the menu. 

This dialog will appear allowing you to enter a custom percentage or height/width values. 
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How do I Change the Layering of 
Annotations? 

Occasionally you may want to change the "stacking" of your annotations. This lesson will 
show you how to do that. 

In this image the number 1 is under our rectangle. We would like the number 1 to appear above 
it. 

Right Click on Annotation 
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Right (or CTL click on Mac) on the annotation and select Order. You can then decide if you want 
to move the annotation back or forward. 

Final Result 

Here you can see that the number 1 is appearing on top of the annotation. 
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How do I Check Spelling? 

Select Edit > Check Spelling 

Or Click the Check Spelling Button 
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If any mistakes are found they will be highlighted. Select the correction you would like to make 
and select Change. 
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How do I Search for Text in a Lesson? 

Select Edit > Find > Find.. 

When editing a lesson the Edit > Find > Find... menu item will bring up a find dialog. 

Enter Text and Click Find 

The Find in Lesson dialog provides a simple means of finding occurrences of a string in your 
lesson. Enter the string and click the Find button. 

Page 88ScreenSteps 2.9



The next occurrence of the string will be highlighted in your lesson. To quickly find the next 
occurrence of the string you can press Command + G on OS X or Control + G on Windows. 
Alternatively you can select the Edit > Find > Find Next menu item. 
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What is Lesson Status? 

You can use the Lesson Status settings to track the progress of your lessons. 

Status Settings 

The status of a lesson is represented by a colored dot that appears next to the lesson title. 
There are four status settings: 

1. None 
2. Not finished/needs revision 
3. Needs Review 
4. Approved 
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Changing Status While Viewing a Manual or the Lesson 
Library 

While viewing the table of contents for a manual or the list of lessons in the Lesson Library you 
can click on the dot to the left of the lesson title to change the status for the lesson. 

Changing Status While Viewing a Lesson 

While viewing a lesson you can click on the dot to the left of the lesson title to change the status 
for the lesson. 
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Setting the Draft Status of a Lesson 

There are two areas where you can set the draft status for a lesson. 

From the Lesson List or in a Manual 

Right click on the lesson and select Draft. 
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When Editing a Lesson 

When editing a lesson, open the inspector (1), select the General tab (2) and check or uncheck 
the Draft checkbox (3). 
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Reordering Steps in a Lesson 

You can always drag steps to reorder them in a lesson. But if you need to move around a 
lot of steps this can become cumbersome. Here are some alternative methods 

Open Inspector Palette 

Select General and Reorder 
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Select the General Tab and drag reorder the steps. 

Using the Menu 

You can also move a step up or down using the Lesson > Step menu. 
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Exporting and Templates 
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Exporting Lessons 

Learn how to export lessons from ScreenSteps to a variety of formats. 

Select Export 

Select the lesson you wish to export and choose Export. 
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Choose Format 

Choose whether you would like to export to Word, PDF, HTML, Package, ScreenSteps Live or 
Blog/Web.  

You must configure your account settings to export to ScreenSteps Live or to your own blog.  

Current blog/wiki services that are directly supported are WordPress, Movable Type, TypePad, 
Blogger, MindTouch, Confluence, Google Sites and Zendesk forums. You can also post to 
Joomla, Drupal and Squarespace using one of the supported formats mentioned. To learn more 
about publishing to the web please see the manual Publishing to Blogs & Wikis. 

Package export is only used for moving lessons between ScreenSteps Libraries.  For example, 
you would use this option if you wanted to send your lesson to anther ScreenSteps user.  They 
would then be able to import the package and edit the lesson. 
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Alternate Method: File Menu 

You can also select File > Export Lesson. 

Alternate Method: Use Contextual Menu 

You can also right click (CTRL + click on Mac) on a lesson to export it. 
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Getting Started With a ScreenSteps Live 
Account 

Shows how to quickly download ScreenSteps 2, create a ScreenSteps Live account and 
configure ScreenSteps 2 for publishing to ScreenSteps Live. 

Create an Account at ScreenSteps Live 
Go to www.screenstepslive.com/signup.  Choose an account type and select Sign Up. 

Sign Up 
Create an account.  An email will be sent to you to activate your account.  Click on the link to 
activate your account. 

Launch ScreenSteps 

Open Preferences 
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Select Web Export 

Create a New Account 

Click on the "+" button at the bottom of the window. 

Enter Account Information 

1. Select ScreenSteps from the drop-down menu for the account type. 
2. Enter your server url.  This will be the account name that you created when you signed up. 

 It will normally look like youraccount.screenstepslive.com. 
3. Enter your user name. 
4. Enter your password. 
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5. Click Test Connection.  If you get a green check-mark then everything is configured correctly. 
 If you get a red x then please make sure that you have entered the information correctly 
and try again. 

Publishing 
With a ScreenSteps Live account you can publish individual lessons or complete manuals. For 
complete details on how to work with ScreenSteps Live please see the ScreenSteps Live manual. 
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Configure ScreenSteps to Upload Lessons to 
Your Blog 

In order to upload a lesson to your blog you need to configure an account that provides the 
information ScreenSteps needs in order to communicate with your blog. This lesson will 
provide a general overview of how to create and configure an account. 

For more detailed information on configuring Web Export accounts please see the 
Publishing to Blogs & Wikis manual. 

Open Preferences 
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Navigate to Web Export 

In the Web Export preference pane use the + button to create a new account. 

Select Account Type 

After clicking the + button a new account will be created. Use the Type menu to select your blog 
type. 
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Now you need to tell ScreenSteps which url (1) to use in order to communicate with your blog 
or wiki. The example url (2) indicates a typical location for the selected Type. For example, 
ScreenSteps uses the XML-RPC protocol to communicate with WordPress so you need to enter 
the url to the xmlrpc.php file in your WordPress installation. 

Enter Your Information 

Fill in your information for the Server (1), User Name (2), and Password (3). To verify that you 
have correctly entered your information click the Test Connection button (4). 

If ScreenSteps is able to communicate with your blog using the supplied information then a 
green check mark will appear next to the Text Connection button. Otherwise an error message 
will be displayed. 

If successful then you can now upload your lessons to your blog using the Blog/Web export 
feature. 
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Rename Account 

Now that you have configured your blog account you can rename the account by double-
clicking on the name in the Accounts list and entering a more meaningful name. 
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Uploading a Lesson to a Blog/Wiki 

Once you have created a Web Export account for your blog in Preferences you can post any 
of your lessons using the Blog/Web export feature. 

Export Lesson to Blog/Web 

If you have a lesson open click on the Export button and select Blog/Web. Alternatively you can 
use the File -> Export Lesson -> Blog/Web menu. 

Note that you can also export a lesson from the Lesson Library lesson list by using the File
menu or by right-clicking on the lesson and selecting Export -> Blog/Web from the contextual 
menu. 
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Configure Export to Blog/Web Dialog 

Before uploading the lesson to your blog for the first time you can configure a couple of 
options. You begin by selecting the Account you would like to upload the lesson to (1). This is 
an account that you have created in the Web Export preference pane. 

Next you configure some of the properties of the lesson. If your blog server supports multiple 
blogs you can specify which blog to upload to lesson to (2). You can also specify a category for 
the lesson (3) as well as whether or not to post the lesson as a draft and/or page (4). 

Once you have configured the lesson properties for the blog post you can choose a template 
(5). The template determines the formatting that will be used to display the lesson in your blog. 

Once you are done configuring the various options click the Upload button to begin uploading 
the lesson.  

A progress dialog will appear while the lesson text and images are uploaded. 
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If all goes well then this dialog will appear. Use the Copy URL to Clipboard button if you would 
like to email the url to your lesson to somebody. 

Updating a Lesson on Your Blog 

When you export a lesson to a blog ScreenSteps remembers the fact that you did so. If you 
attempt to export the lesson to the same blog again the Export to Blog/Web dialog will appear 
slightly different. You can still specify whether or not to post as a draft (1) and which template 
to use (2) but you cannot change the category. 

Clicking the Upload Again (3) button will replace the existing blog post. 
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Configuring a Clarify-it.com account 

This lesson will show you how to configure ScreenSteps to instantly publish your lessons to 
the Clarify-it.com sharing service. 

You can use Clarify-it.com to share the documents you create in ScreenSteps Desktop with 
the world. Instantly get a URL back that you can share via Twitter, Facebook, instant 
messages, emails, forum posts or wherever else you need to share your ScreenSteps 
documents. 

Open Preferences 

To enter your Clarify-it.com credentials or create an account open Preferences. The image on 
the left shows how to do this on OS X. The image on the right shows how to do this on 
Windows. 
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Enter Username and Password 

In the Clarify-it.com tab, enter your username (or email address) that you used to create your 
account and password in the provided fields. If you would like the data sent between 
ScreenSteps desktop and Clarify-it.com encrypted then check the Use SSL box as well. 

Test The Connection 

After entering your information click the Test Connection button. This will verify that your 
username and password are correct. 

If you see the green check mark then you are ready to begin sharing your lessons with Clarify-
it.com. 
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Assigning a File Name to use for a Lesson or 
Manual 

In version 2.8.9 ScreenSteps added the ability to specify the file name to use when 
exporting a lesson or manual to files on disk (e.g. HTML). 

Setting the File Name for Lessons 

You can assign the default file name to use when exporting a lesson via the property inspector. 
Just select the General tab when a lesson is selected and fill in the File name property. Do not 
add a file name extension (e.g. .html) as one will be added based on the format you are 
exporting to. 
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Setting the File Name for Manuals 

You can assign the default file name to use when exporting a manual via the property 
inspector. Just select the General tab when a lesson is selected and fill in the File name 
property. Do not add a file name extension (e.g. .html) as one will be added based on the 
format you are exporting to. 
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Selecting Word, PDF and HTML Templates 
for Lessons 

Learn how to choose a template for a lesson. 

Select Export > Word, HTML or PDF 

Select Word, PDF or HTML from the Export menu. 
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Select Template 

Select a template from the list (1) and select Export (2). If you would like the selected template 
to be your default template then check the Set as Default (3) checkbox. You will then no longer 
see this screen when you export. Your default template will be used each time. If you need to 
change the default template later on you can do so in preferences. 
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Changing/Setting the Default Template 

This lesson will teach you how to change or clear the default Word, HTML or PDF template. 

Open Preferences 
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Select Either Word Templates, PDF Templates or HTML 
Templates 

If a default template has been set it will be in bold. 
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Clear Default Template 

Right click on the template name and select Clear Default to clear the default template. 

Set a Default Template 

Right click on a different template and select Set as Default to set a new default template.  If 
you don't set any default template then you will see the template selector each time you export 
a lesson. 

You can set a default template for Word, PDF and HTML exports. 

Restoring Default Templates 
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If you ever need to restore the default templates that come with ScreenSteps to their factory 
state then look for the Restore Defaults button at the bottom of the template preference 
pane. 
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Overriding the Default Template for a 
Lesson 

Learn how to override your default template setting on a per lesson basis. This can be 
handy if you only want to use a template for a few specific lessons. 

Open Inspector 

Select a lesson and open the Inspector. 

Choose a Template 
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You can select a specific template for Word, PDF and HTML. 

If you choose a specific template then that template will always be used when exporting the 
lesson. 
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How Can I See Which Web Servers I've 
Uploaded a Lesson To? 

This lesson will show you how to see which web servers you have posted a lesson to. 

The Lesson Inspector 

The Lesson Inspector has a Web tab (1) that shows which of your Web Export accounts the 
selected lesson has been uploaded to (2). 
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Links 

Clicking on a web export account (1) will list links to that lesson on the web server (2). 

You can use the icons to the right of the link name to view the lesson in your browser (1) or 
copy the url to the lesson to the clipboard (2). 
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Breaking a Link Between a Lesson and a 
Web Server 

As of version 2.8.7 you can break the link between a lesson and a web server. This allows 
you to upload the lesson to the web server as a new document rather than updating the 
existing document. 

Breaking a Link Between a Lesson and a Web Server 

If you need to break the link between a lesson and a web server then select the server and 
press the Delete or Backspace key. 
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Confirm 

You will be shown a dialog asking you whether or not you want to break the link. Click the 
Break Link button to break the link. The next time you export the lesson to the server a new 
lesson will be created rather than the existing lesson being updated. 
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How to insert a ScreenSteps Lesson into a 
forum post or other web application 
By posting your lesson to a Clarify-it.com account you will get HTML back that you can embed in 
a forum post, wiki, project management application or any other web application that accepts 
HTML. 

Before you follow the steps in this lesson you must create a Clarify-it.com account. 

Select Share > Clarify-it.com 

Your lesson will be uploaded to Clarify-it.com. 

Page 126ScreenSteps 2.9

https://bmls.screenstepslive.com/20492?data-resolve-url=true&data-manual-id=


Copy HTML 

After you lesson is uploaded you will see a dialog box with several items you can copy to your 
clipboard. Click the HTML clipboard icon and paste the HTML into your forum post or web 
application. 

The HTML template will give you un-styled HTML. The Styled HTML template has some basic 
inline styling applied to the HTML. 
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Exporting to the System 
Clipboard 
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Exporting a Lesson to the Clipboard as HTML 

With ScreenSteps you can quickly copy any lesson to the system clipboard in HTML format. 
You can then paste the lesson into an email program like Outlook or Apple Mail and send 
the lesson to someone. 

Exporting to Clipboard 

If you have a lesson open or you have a lesson selected in the lesson library list you can click on 
the Share icon in the toolbar (1). Select HTML to Clipboard in the menu that appears (2). 

The lesson will be exported using the assigned Clipboard HTML template and the resulting data 
will be placed on the system clipboard in HTML format. 
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You can also right-click on a lesson in any list and select the Share > HTML to Clipboard option. 
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Exporting a Lesson to the Clipboard as PDF 

With ScreenSteps you can quickly copy the path to a PDF version of a lesson to the system 
clipboard. You can then paste the file path into any system file dialog or application that 
supports file paths. 

This feature is useful for uploading lessons using a browser or attaching lessons to emails 
created by applications that don't support the HTML format on the system clipboard. 

Exporting to Clipboard 

If you have a lesson open or you have a lesson selected in the lesson library list you can click on 
the Share icon in the toolbar (1). Select PDF to Clipboard in the menu that appears (2). 

A PDF file will be created in a temporary folder on your computer. The path to the file will be 
placed on the system clipboard. 
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You can also right-click on a lesson in any list and select the Share > PDF to Clipboard option. 
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How do I Specify Which Template Is Used 
When Exporting To Clipboard? 

When exporting a lesson to the clipboard as HTML or PDF you can specify a template that 
will be used to output the lesson. This lesson explains how. 

Open Preferences 
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Select Template From General Tab 

On the General tab you can select the template you would like to use when copying a lesson to 
the clipboard as PDF (2) or HTML (3). 

The list of PDF templates (2) is taken from the PDF templates available in the PDF Templates 
tab. 

The list of HTML templates (3) is taken from the the Clipboard folder in the HTML templates 
folder. For more information on the templates folder please see our manual on Customizing 
HTML Templates. 
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How do I paste the path to the PDF file into 
a file selection dialog on OS X? 

This lesson will show you how to navigate to the PDF file you copied to the clipboard into an 
OS X file selection dialog window. 

Note that you must first copy a document to the clipboard as PDF for these instructions to 
work. 

The File Selection Dialog 

This is what a file selection dialog looks like. 
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Open "Go to the folder:" Dialog 

With the file dialog window open, hold down the COMMAND + SHIFT + G keys to open the Go 
to the folder window. 

Paste URL 

Use COMMAND + V to paste the PDF file path into the field. Click the Go button. 
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The PDF file is now selected in the dialog (1). Click the Select button to select the file (2). 
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How do I paste the path to the PDF file into 
a file selection dialog on Windows? 

This lesson will show you how to navigate to the PDF file you copied to the clipboard into a 
Windows file selection dialog window. 

Note that you must first copy a document to the clipboard as PDF for these instructions to 
work. 

The File Selection Dialog 

This is what a file selection dialog looks like. 
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Paste The File Path Into the "File name" Field 

Click in the "File name" field of the dialog. Use CONTROL + V to paste the path to the PDF file 
into the field (1). 

Click the Open button to select the file (2). 
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Why don't images show up in emails I send 
that I pasted a lesson into? 

When pasting the rich text representation of a document on the clipboard into an email 
program you need to check a few settings to ensure that the images will be sent with the 
email. 

This lesson will show you the settings to check for Apple Mail and Outlook Express. 

Example: Mail 

In Apple Mail you need to make sure your email message is sent using the Rich Text format. 

Apple Mail allows you to set a default message format when composing email messages. In the 
Compose tab of the preferences window (1) you can set the default Message Format to Plain 
Text or Rich Text (2). This setting will apply to all new email messages you write. 
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Mail: Toggling the Setting of an Existing Message 

If you normally send email messages as Plain Text then you can change the formatting on a 
per-message basis. After creating a new message select Make Rich Text from the Format 
menu. 

You can now paste the document you exported to the clipboard as rich text into the email. 
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Example: Outlook Express 6 

In order to send the document images in email messages you send from Outlook you need to 
ensure that the Mail Sending Format in Options > Send is set to HTML (1). 

After checking this setting click on the HTML Settings... button (2). 

Make sure that Send pictures with messages is checked as well. 
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Searching/Filtering 
Lessons 
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Searching in Tag Mode 

This lesson will give you an overview of how to search/filter lessons in Tags mode. 

Select Tag Mode 

The options we will show in this lesson apply when you are in Tags mode. 

Search/Filter Options 

1. Search field 
2. Lesson filter 
3. Sort order 
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Lesson Filter 

You have a few options for filtering lessons.  Unassigned to Tag will only display lessons that 
have not been tagged yet. You can also filter Draft lessons or lessons that have a specific status. 

Sort 

You can sort lessons by Title or the last time they were modified. 

Search Text 

Search text will search lesson and step text for a match. 

Tip: You can search for tags using the search by means of the "tag:" string. Here are some 
examples. 

Search for lessons tagged with "help": 
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tag:help 

Search for lessons tagged with "version 2": 

tag:"version 2" 

Search for lessons tagged with "help" and "version 2": 

tag:help,"version 2" 
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Tags 
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How Do I Tag a Lesson? 

Tags can help you categorize lessons.  This lesson will show you the various ways you can 
add tags to a lesson. 

Select "Add Tag" 

To add a tag to a lesson you are editing, load a lesson and select Add Tag. 

Enter Tag Title 

Type in the tag you want to add. You can separate tags with commas or by pressing tag. 
ScreenSteps will try to auto-complete the tag using tags you have already added to your library. 
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This is what the tag will look like once it has been added. 

Add Another Tag 

To add additional tags just click to the right of the last tag and start typing. 
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How Do I Tag Multiple Lessons Quickly 
(Using the Tag Palette)? 

Sometimes you want to quickly tag multiple lessons. The best way to do this is to use the 
Tag Palette. 

Select View > Show Tag Palette 

Drag Tag Onto Lessons 
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The Tag Palette will display a list of your current tags. You can create new tags but pressing 
Add Tag (1). 

To add a tag to a lesson just drag the tag from the Tag Palette to the lesson. 

Repeat 

Here you can see that the tag has been added to the lesson. You can use this lesson to quickly 
tag multiple lessons. 
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How do I delete tags from a lesson? 

Select the tag 

Press Delete on Your Keyboard 

Page 152ScreenSteps 2.9



Tag Will be Deleted 
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How do I delete all instances of a tag from 
my library? 

Select Tag in Tag Mode 

Make sure you are in Tags mode (1) and select the tag you want to delete (2). 

Press Delete 

Press delete on your keyboard and click Delete on the dialog box to confirm. The tag will be 
removed from your library. 
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Tagging Tip - Dragging Lessons Onto Tags in 
Tag Mode 

Learn how to add tags to a lesson by simply dragging and dropping. 

Make Sure You Are In Tag Mode 

Drag Lesson Onto Tag 
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Drag the lesson onto a tag. 

Here you can see that the tag has been added to the lesson. 
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Manuals 
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How to Create a Manual and Stub Out 
Lessons 

Manuals allow you to group your lessons much like you would a user manual. 

Select Manuals Mode 

Select Manuals mode. 

Select New Manual 
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Enter a Title 

Name the Chapter 

Chapters help you organize lessons in your manual. By default one will be created for you. You 
can renamed the chapter by double clicking on it. 

Add Additional Chapters 

Click New Chapter to add additional chapters. 
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Add Lessons 

You can create lesson stubs within a chapter.  These will be empty lessons that you can fill in 
later.  Select New Lesson to add a lesson to a chapter. 

Name the Stubbed Lesson 

Enter a name for the lesson and press return. Continue this process, adding additional lessons 
until you have finished stubbing out your manual. 
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Adding Existing Lessons To Manuals Using 
the Lesson Palette 

This lesson will show you how to add existing lessons to manuals using the Lesson Palette. 
 This is a very fast way of assembling topics from existing lessons. 

Create a Manual 

Create a new manual and select it. 

Open the Lesson Palette 

Select View > Show Lesson Palette. 
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Lesson Palette Overview 

The Lesson Palette displays all of the lessons in the current library. You can search (1) and sort 
(2) lessons.  The lessons will be displayed in a list (3).  The description for the selected lesson will 
be displayed below (4). 

Page 162ScreenSteps 2.9



Drag Lessons Onto Chapters 

Just drag lessons onto a chapter to add them. 

Here I have added a single lesson to the "Getting Started" chapter. 

Repeat the process, adding additional lessons to your manual. 

Tip: You can also drag lessons from the Lesson Palette onto Tags. 
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What are Draft Chapters? 

Draft chapters are chapters that you are working on but not yet finished. By default a draft 
chapter will not be included when your manual is exported. This can be useful if you have 
some content that you are working on that is not ready for distribution yet. 

Marking a Chapter As A Draft 

To mark a chapter as a draft, just check the Draft checkbox. 
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How do I reorder Chapters? 

Click on Chapter Title 
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Drag to Reorder the Chapter 

That's it 
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Exporting a Manual to Word, PDF or HTML 
(Pro only) 

Learn how to export an HTML or PDF version of a Manual.  This will contain a table of 
contents that links to all of the lessons in your manual. 

NOTE: This feature is only available in the Pro version of ScreenSteps. 

Select Manual 

Select the manual you would like to export. 
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Select Export Format 

Select Word, PDF, HTML or Package from the export menu. 

Note: You can also export manuals to ScreenSteps Live but the process is slightly different and 
will be covered in a different lesson. 
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Select a Template 

Select the template you would like to use (1).  You can choose to make the selected template 
the default template for manual exports (2).  

Checking Export Drafts (3) will include draft content in your exported manual. 

If you just want to include lessons with a particular status you can check/uncheck status boxes 
as needed (4). Once you are done select Export (5). 

NOTE: You can edit your templates in the ScreenSteps Preferences. 
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Alternate Method: File Menu 

You can also select the Topic and then choose File > Export Manual. 

1. Word - A manual with a table of contents will be exported in DOCX format (compatible with 
Word and various other word processors). 

2. PDF - A PDF manual with a table of contents will be created for you. 
3. HTML - Various HTML files and folders will be created.  You will be asked where you want to 

save the files (you should probably create a folder to store all of the files that will be 
exported). 

4. ScreenSteps Live - Your manual will be published to ScreenSteps Live. You must have a 
ScreenSteps Live account to use this option. 

5. Package - A single package file will be created.  This is used to move the manual between 
ScreenSteps Libraries.  For example, you would use this if you needed to send a manual that 
you were working on to another ScreenSteps user. That user could then edit the lessons in 
the manual. 
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Alternate Method: Use Contextual Menu 

Right click on a topic and select Export. You have the same options as mentioned above. 
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Choosing a Template for a Manual (Pro only) 

Learn how to choose the HTML or PDF template for a manual. 

Inspect Manual 

Right click on a manual and select Inspect. 
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Choose Template 

Choose the template you would like to use for the manual.  The template will be used the next 
time you export. 
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How to see which Manuals a Lesson belongs 
to 

Select Lesson and press key command 

1. Select the lesson from the list. 
2. Press the COMMAND + SHIFT + M on OS X or CONTROL+ SHIFT + M on Windows. The 

manuals that contain the selected lesson will highlight on the left. 
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How to drag multiple Lessons into a Manual 

Select Lessons and Drag 
1. Select Lessons from the sidebar. 
2. Select multiple lessons by holding down the shift key (or cmd/alt key). 
3. Drag them onto a manual. 

Page 175ScreenSteps 2.9



The Library Folder 
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Introduction To The ScreenSteps Library 

ScreenSteps stores all of your lessons in a single library folder. There is no need to worry 
about where to save each lesson you create. Just open ScreenSteps and start creating. 

The Default ScreenSteps Library 

The first time ScreenSteps is launched on a computer it will create a library folder named 
ScreenSteps Library (1) in your the user documents folder. On OS X this is in the 
~/Documents folder. On Windows this in My Documents. 

A file named Library.data (2) is created inside of the library folder. This is the database file that 
contains all of the information about your lessons. 
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Lessons 

Each lesson in ScreenSteps has a folder in the Lessons subfolder (1). Each numbered folder 
corresponds to one of your lessons in your ScreenSteps library. 

Lesson Media 

Each lesson folder has two subfolders - Data and Media. The Media folder contains the original 
images for each step in the lesson. The Data folder contains the image that is displayed in the 
ScreenSteps program. 
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Locate Library Folder 

If your library is open in ScreenSteps you can use the File > Reveal Library Folder menu to 
reveal the folder in Finder or Windows Explorer. 
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Locating Lesson Media 

Since the lesson folders are named using numbers it is not apparent which lesson folder 
corresponds to which lesson in ScreenSteps. If you need to locate lesson media in your library 
folder you can: 

1. Open the lesson in ScreenSteps. 
2. Right-click on a step image. 
3. Select Reveal File from the contextual menu. 
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Creating New Libraries 

ScreenSteps enables you to work with multiple libraries. This can be useful if you have 
different products that you are documenting or want to keep work content separate from 
personal content. This lesson will show you how to create a new library. 

Creating a New Library 

You can create a new library using the File menu. Select File -> New Library... 
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and you will be presented with a folder selection dialog. 

Create Folder For Library 
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Create a new folder (1) that will server as a ScreenSteps Library folder. This is where all of the 
images and data for your library will be stored. 

Select Folder 

Once you have created a new folder, select it (1) and click OK (2). You have now created a new 
ScreenSteps library folder. 
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Opening Libraries 

ScreenSteps allows you to work with multiple libraries. This lesson will show you how to 
switch between different libraries while working in ScreenSteps. 

One thing to note is that ScreenSteps will always open the library that was opened when 
ScreenSteps last quit. 

Open Folder Browser Dialog 

To open an existing ScreenSteps library you use the File menu. Select File -> Open Library.... 
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Select Library Folder 

Select a ScreenSteps library folder (1) and click OK (2). 

Note: A ScreenSteps library folder will have a Library.data file and a Lessons folder inside of it. 
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Renaming a Library 

If you need to rename a library in ScreenSteps the current solution is to use the Finder (OS 
X) or Windows Explorer (Windows). This lesson will show you how. 

Locate Library Folder 

If your library is open in ScreenSteps you can use the File > Reveal Library Folder menu to 
reveal the folder in Finder or Windows Explorer. 
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Now that the folder has been revealed you will be tempted to rename it. Don't. ScreenSteps 
doesn't like it when you move the library folder you are working on. 

Quit ScreenSteps 
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Before you rename the folder make sure that the library is not open in ScreenSteps. You can do 
this by opening another library or quitting Revolution. 

Rename Folder 

Now you can rename the folder. 

Open the Renamed Library 
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How to Move a Library From One Computer 
to Another 

This article will tell you how to move your ScreenSteps Lessons library from one machine to 
another, for example from your desktop computer to a laptop. 

Reveal Library Folder 

If your library is open in ScreenSteps you can use the File > Reveal Library Folder menu to 
reveal the folder in Finder or Windows Explorer. 
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Copy Entire Folder 

When you reveal the lesson library you are going to see a folder that will have two items in it: 

1. The Lessons folder 
2. The Library.data file. 

You need to copy both of these items. What you really want to copy is the folder that contains 
these two items. In the example above you would copy the ScreenSteps Library (3) folder. You 
can copy this over your network or onto a removable hard drive. 

Open Library on New Machine 

Once you are on your new machine and have launched ScreenSteps select File > Open Library. 
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1. Select the folder that contains the Lessons and Library.data file (in this example 
ScreenSteps Library) 

2. Select Choose 

That's it. 
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Importing a Library 

This lesson will show you how to import one ScreenSteps Library into another. 

Select Library to Import 

Begin by opening the ScreenSteps Library you would like to add lessons to. Then select the File 
> Import Library... menu item. 
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Select ScreenSteps Library Folder 

A folder selection dialog will appear. Select the ScreenSteps Library folder you would like to 
import. A ScreenSteps Library folder contains a file named Library.data and a folder named 
Lessons. 

After selecting the folder the import process will begin. 
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The Result 

When the import operation is complete all content from the library you selected will have been 
imported into the current library. 
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Customizing Output 
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Configuring HTML and Blog Templates 

This lesson will show you how to do some basic customization to HTML templates in 
ScreenSteps 2. 

To learn more about HTML templates and how to customize them take a look at the 
"Customizing HTML Templates in ScreenSteps" manual. 

Open Preferences 
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Select HTML Templates 

Screen Overview 

There are four types of templates: 
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1. Lesson Templates: These apply when exporting lessons. 
2. Manual Templates (Pro only): These apply when exporting manuals. 
3. Blog Templates: These are used when posting to your own blog. 
4. Clipboard Templates: These are used when you export HTML to the system clipboard. 

Select the tab for the type of template you wish to edit. 

Template Configuration 

Template configuration controls appear to the right of each template type.  The controls will 
apply to the selected template. 

Font Family 
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Not all systems have the same fonts installed when viewing web pages.  For this reason you 
don't select a font, but instead a font family.  Basically, one of the fonts in the family should be 
installed on any system that will view your page.  

Select the font family you would like to use for your template. 

Image Format 

You can also adjust the image type to use as well as JPEG Quality. 

Image Position 

You can select whether to have the image appear above instructional text or to the right. 

If you want your images to appear below the step text then you will need to manually modify 
the HTML template as described in our manual on customizing HTML templates. 

Quick Tip: If you use large images in your lessons we suggest choosing the Above option. 

Adjust Max Image Width 
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Here you can set the maximum images width that will be allowed when exporting to this 
template (in pixels). Any images that are wider than this value will be scaled down. 

Quick Tip: Use this setting to makes images fit inside of your blog or wiki template for your site. 
We suggest setting the value at about 10 pixels less than the width of your content area. 

Viewing the Templates Folder 

If you would like to view/edit the actual template files right-click on a template and select 
Reveal Template Folder (1) or click on the Reveal Template Folder icon (2). 

That's It 
To see if you like your new settings, export a lesson.  If you want to make further adjustments 
to the HTML template you will have to actually edit the HTML template document. 
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Customizing PDF Output 

ScreenSteps allows you to customize PDF output using PDF templates. A PDF template 
controls how your individual lessons or manuals look when you export to PDF. 

Open Preferences 
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Create A PDF Template 

Click on the PDF Templates icon in the toolbar (1). Now click on the + button (2) to create a new 
template. A new entry will appear in the Templates list (3). At this point you can enter a name 
for your template. 
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Configure Document Settings 

Use the Document tab to change page size, orientation, font and other document specific 
settings. 
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Configure Title Page for Manuals 

If you are using ScreenSteps Pro you can customize the title page that appears at the front of 
each manual. On the Manual Title Page tab you can do things like add a company logo, add a 
footer and customize the text size and color. 

When entering footer text you can use HTML markup to customize text styling. For example, if 
you wanted to have a link to a web page that was bold and italicized you could enter the 
following text in the Footer Text field: 

<b><i><a href="http://www.screensteps.com">Go to our website</a></i></b> 

Note that if you want to have multiple paragraphs in the footer you must surround each 
paragraph with "<p>" tags. 

<p>Paragraph 1</p> 

<p>Paragraph 2</p> 
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Configure Lesson Instruction Settings 

The Lesson tab allows you to customize the look and feel of your lessons. As you experiment 
with the step title settings the preview (1) will update. 
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Configuring Header & Footer 

The Header & Footer allows you to customize the header and footer that will appear on each 
lesson page. In addition to selecting a logo for the header you can enter text that will appear in 
the bottom-right corner of the page. This screenshot demonstrates how you can use HTML 
markup to add hyperlinks in the footer. This example links to the screensteps.com home page. 
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The ScreenSteps Templates Folder 

ScreenSteps allows you to customize output using templates. These templates are stored in 
a folder on your computer that you can access if you would like to add, modify or share 
them. 

To share a template simply send the person you want to share it with the template folder 
(HTML) or file (PDF and Word). The recipient can then place the folder or file in their 
template folder. 

Open Templates Folder 

To open the ScreenSteps template folder click on the Reveal template folder button (folder 
icon) that appears in the HTML Templates preference pane. This will reveal the template folder 
for lessons, manuals, blogs or the clipboard depending on which tab you have selected when 
you click the button. This folder is located in your user application data support folder. 
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The Templates Folder 

The templates folder contains 3 subfolders - DOCX, HTML and PDF. 

The DOCX Folder 

The DOCX folder contains 2 subfolders - Lesson and Topic (Manuals were previously called 
Topics). Each of these subfolders contains template files. As you can see the list of templates in 
the Word Templates preference pane Manual tab (1) is generated from the list of folders in the 
Topic folder (2). 

You can add, duplicate or remove template files and they will appear the next time you export a 
lesson or manual or to Word. 
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The HTML Folder 

The HTML folder contains 3 subfolders - Blog, Lesson and Topic (Manuals were previously 
called Topics). Each of these subfolders contains template folders. As you can see the list of 
templates in the HTML Templates preference pane (1) is generated from the list of folders in 
the Lesson folder (2). 

You can add, duplicate or remove template folders and they will appear the next time you 
export a lesson or manual or to a blog. HTML templates are text based and can be customized 
by anyone using a text editor. 
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The PDF Template Folder 

The PDF folder contains a single folder named Lesson.  This folder contains the PDF templates 
(1) that you see in the PDF Templates preference pane (2). 

PDF templates cannot be modified outside of ScreenSteps but if someone emails you a 
template you can copy it into this folder. The template will then be available the next time you 
export a lesson or topic as PDF. 
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Customizing HTML Templates 
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Updating Your Templates 

The first time you launch ScreenSteps on a computer a Templates folder is created. You can 
then update and modify those templates as you wish. If you would like to restore the 
factory default templates or would like to update your templates because ScreenSteps 
introduced a new template feature, this lesson will show you how. 

Restore Defaults Button 

At the bottom of the Word, PDF and HTML templates panes you will find a Restore Defaults 
button. To reinstall the original versions of the templates that shipped with ScreenSteps click 
this button. If you have made any changes to these templates those changes will be lost. No 
changes will be made to custom templates you've created, however. 
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Additional Topics 
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Editing Images in an External Editor 

Learn how to edit images in any external editor and have your changes show up 
automatically in ScreenSteps 2. 

Right Click on Image 

Right click (or ctrl-click on Mac) on the image you would like to edit and select Edit in External 
Editor. 
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Select Application 

If you haven't already selected your image editor a dialog will appear allowing you to select the 
application you would like to use to edit the image.  In this example I am going to select 
Photoshop. 

Edit, Save, Close 
Edit the image, save and close it.  Whatever changes you make will be shown in ScreenSteps 2. 
Remember that you must save the file in the same format.  This means that if you are using an 
image editor that utilizes layers you will need to flatten the image before saving.  If you ever 
wish to change the editing application you can do so in the Preferences menu. 
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How to copy an image to the clipboard 

Click Clipboard icon 

Clicking the clipboard icon for a step will copy the step image along with any annotations to 
your system clipboard. 
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Importing a Plain Text File Into a Lesson 

ScreenSteps can import text files into a lesson. This lesson will show you how. 

File > Import 

Choose the File > Import... menu item. 

Page 217ScreenSteps 2.9



Select Text File 

The dialog that appears allows you to select a .txt file. Select the file you would like to import. 
The file should use the platform specific encoding of the platform you are running ScreenSteps 
on. 

A New Step Is Created 

A new step will be created using the contents of the text file. 
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Syncing Image Filenames to Step Titles 

This lesson will show you how to synch image filenames to step titles.  This can be handy if 
you are going to use images acquired with ScreenSteps in another application such as 
PowerPoint or Keynote. 

Here is the scenario.  You have created a ScreenSteps lesson and now you want to use some of 
the images in another application such as PowerPoint or Keynote.  But your images filenames 
look like the picture above.  It isn't very easy to tell from the title which image is which. 

But look at the lesson that contains the images.  You already have step titles for each image. 
 Why not just apply those names to the image files?  Well, you can. 
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Select Sync Image Names to Step Titles 

Choose Lesson > Sync Image Names to Step Titles. 

Reveal File 

Now, right click (or ctrl-click on Mac) and select Reveal File. 
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Now you can see that my images have all been renamed so something that is much more 
useful than before. 

IMPORTANT: If you are going to import these images into another application make sure that 
you COPY the and DO NOT move them.  If you move the images out of this folder then 
ScreenSteps won't be able to find them when you load the lesson again. 

Set Sync Names as the Default in Preferences 

You can also set this as the default behavior.  ScreenSteps will update filenames each time you 
change a step title.  Note that this can slow down performance a bit. To do it, open Preferences
(Edit > Preferences on Windows). 
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Then check it as a preference.  Now each time you update a step title the image filename will be 
updated as well. 
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Using Split Step 

See how you can take traditional, text based documentation and turn it into something 
visual in just a couple of minutes. 

Original Material 

Here is some documentation for Apple's Pages application. We are going to transform this into 
a visual tutorial. First, copy the text from the original lesson. 
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Create a Lesson In ScreenSteps 

Create an new lesson in ScreenSteps and give it a title. 

Create a Blank Step 
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Paste Text 

Paste the text from the original document into the step. 

Split the Step 

The problem here is that we have text that describes four steps pasted into a single 
ScreenSteps step. So, we are just going to split it. Here I have placed the cursor at the end of the 
first step. 
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Right click (or ctrl-click on Mac) and select Split Step At Insertion Point. The step will be split 
wherever you have placed the cursor. 

Here I have split each list item into its own step. 
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Add Images 

Click on the Replace Step Image icon and capture an image for that step. 

Here you can see that I have added an image. 

Now, reading through the text I can see that they actually combined three steps into one. So I 
will split it up a bit more. 
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Here you can see that I split the instructions mid-sentence. 

Add Images, Annotations and Step Titles 
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Add annotations and step titles. I also reformatted the original text. All in all it took me about 5 
minutes. 
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How to Split a Lesson in Two (Create Two 
Smaller Lessons Out of One Large Lesson) 

This lesson will show you how to split a long lesson into smaller lessons. Breaking your 
lessons up into smaller sections will make your lessons easier to keep up to date. 

Select First Step of New Lesson 

Select the step that you want to be the first step of the new lesson. 
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Select Split Lesson At This Step 

Right click on the step (not the image) and select Split Lesson At This Step. This is what will 
happen. 

1. The step that you clicked on and all steps after it will be removed from the current lessons. 
2. A new lesson will be created with the step you selected as the first step of that lesson. 
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Duplicating Lessons and Manuals 

This lesson will teach you how to duplicate Lessons and Manuals. 

Duplicate a Lesson 

To duplicate a lesson simply select a lesson and choose Lesson > Duplicate Lesson.  A 
complete copy of the lesson will be made. 
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Duplicate Manual 

To duplicate a manual, right click (ctrl-click on Mac) on the manual and select Duplicate.  

You will be asked if you want to duplicate all of the lessons or just reference them. If you only 
reference the lessons then any changes you make to a lesson will show up in both the original 
manual and the duplicated manual. 

After you select an option the manual will be duplicated. 
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Uploading HTML Lessons to Your Mobile Me 
or .Mac Site 

This lesson will teach you how to upload lessons created in ScreenSteps to your .Mac site. 

Export Your Lesson as HTML 

Open your lesson in ScreenSteps and select Export > HTML. 
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Create a Folder on your Local Drive 

I create a new folder called "lessons" on my local drive as well, either on my desktop or in my 
Documents folder. 

Page 235ScreenSteps 2.9



Save HTML File in That Folder 

Select the folder that you created and select Save. 

Open Your iDisk 

Select Finder, and then Go > iDisk > My iDisk. 
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Drag Lessons Folder to Your iDisk Web > Sites Folder 

Drag the lessons folder that contains the lesson you exported to the Web/Sites folder on your 
iDisk. Make sure you drag the lessons folder and not just its contents. 

View Lessons in Browser 

You can now enter the url for your lesson in your browser.  It will be http://web.me.com/
YOUR_USER_NAME/lessons/THE_TITLE OF_THE 
HTML_FILE_YOU_EXPORTED_FROM_SCREENSTEPS.  For example it might be 
"http://web.me.com/greg/
lessons/Customizing_Lesson_Navigation_Links_In_Topic_Templates.html". 
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Sharing ScreenSteps Lessons with Other 
Users of ScreenSteps 

This lesson will show you how to export a ScreenSteps lesson as a package. The package 
can then be imported into another ScreenSteps library for further editing. This is a how you 
can send lessons between yourself and another user of ScreenSteps. 

Select Lesson 

Select the lesson you want to export. 

You can shift click (Windows or Mac) to select multiple contiguous lessons. 

You can cmd-click on Mac to select multiple non contiguous lessons. 
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Export a Package 

From the Export menu, select Package. 
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Select File > Export Lesson as Package 

Alternatively you can use the File menu. After selecting Package, choose a place to save it on 
your hard drive and give it a name. Once it is saved you can email it to a colleague. 
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Import a Package 

If you receive a package just select File > Import. \ Choose the package file from your hard 
drive. It will be imported into your library. 
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How do I Resize an Image Without Resizing 
Annotations? 

In ScreenSteps you can specify the dimensions that an image will have when you export the 
lesson. When resizing the image the default behavior is to resize image annotations. This 
lesson will show you how to change the default behavior. 

The Image 

Here is a step image that has a sequence annotation. We are going to resize this image without 
affecting the size of the sequence annotation. 
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The Resize Menu 

To resize the image you click on the resize arrow underneath the image (1). This will display the 
resizing menu. If there is a check mark next to Scale Annotations then select Scale 
Annotations to turn off annotation scaling (2). 

Resize The Image 

Now you can resize your image using the same menu. 
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The Result 

The image has now been resized but the sequence annotation has not changed. 
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How to have ScreenSteps automatically 
check for updates 

As of version 2.9 ScreenSteps can automatically check for updates each time it launches. 

Open Preferences and then check the box 
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Working with 
ScreenSteps Live 
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How do I Upload a Manual to ScreenSteps 
Live from ScreenSteps Desktop? 

Select Your Manual 

Select Export > ScreenSteps Live 
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Configure Options 

Configure your options for the upload. 

1. Most of the time you will select Create new manual or Update existing manual if you have 
previously uploaded the manual. 

2. In the PDF section you can choose which PDF template you would like to use and whether 
you would like to upload PDFs for each individual lesson, the entire manual, or both. 

3. Here you can toggle comments, upload packages, and filter manual lessons by status. 

Once you have configured your settings, select Upload. 

4. You may want to publish the manual directly to a space. Check this box before uploading if 
you would like to do that. NOTE: If you are an editor or author user you will have to attach your 
manual to a space. 

5. You can also add a permalink for the manual when you create it. 
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How do I Update My Local Manual With 
Changes From the Version on my 
ScreenSteps Live Account? 

This lesson will teach you how to download changes to your manual from your ScreenSteps 
account. If you are collaboratively working on a manual as a team it is advised that you do 
this each time before you working on a manual. This will ensure that you have the latest 
content.. 

Open the Manual Inspector 

Select the manual you want to update (1) and open the inspector (2). 
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Select Your ScreenSteps Account 

Select the Web tab (1) in the inspector. Select the ScreenSteps Live from which you wish to 
download changes (2). 
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Select Download Changes From Server 

Select Next 
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Currently only Automatic Syncing is available. What does this mean? Automatic Syncing merge 
the chapter structure between your local version and the version on ScreenSteps Live. You will 
still be able to determine how you want your actual lesson content to be updated. 

Resolve Conflicts Screen 

1. If there are conflicts then a list of conflicts will appear. 

2. Click the Show History link to view the history of edits for the selected lesson or chapter. 

3. The Download Updates button will not be enabled until all conflicts have been resolved. 

Tip - You can quickly accept all changes from the server by selecting Accept all server changes 
from Bulk Actions (4). 
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Resolve Conflict 

There are two types of conflicts: 

• Content Conflicts: The actual lesson contents are different. 

• Meta Data Conflicts: The tags or status setting a for a lesson are different. 

This is an example of a meta data conflict. I can select to: 

1. Keep the local version 

2. Keep the ScreenSteps Live version 

In this example I have decided to keep the server version. 
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Download Updates 

Once all of the conflicts are resolved, click Download Updates. Your local manual will be 
updated. 
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Comparing Manuals Between ScreenSteps 
Desktop and ScreenSteps 

This lesson will show you how to compare your manuals in your desktop with ScreenSteps. 
If you are working with multiple authors on ScreenSteps or you tend to work from multiple 
computers this lesson will show you a quick way to make sure that you are always working 
with the latest material before you start working on creating or updating content. 

IMPORTANT - This feature requires ScreenSteps 2.8.7 or later. 

Automatically Comparing Manuals 

If you want ScreenSteps to automatically compare your manuals with ScreenSteps Live each 
time you open it then open preferences and make sure that Compare manuals to 
ScreenSteps Live when first opened is checked. 
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Manually Compare Contents With ScreenSteps Live 

To compare your manual with ScreenSteps Live manually, right click on the manual and select 
Compare With ScreenSteps Live > Your Account Name. 

Select Manual 
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Now, each time you select a manual that has been previously uploaded it will be compared to 
the manual on ScreenSteps. 

If there are differences you will receive a notification. 

Viewing Differences 

Any lesson or chapter that is different will have a yellow warning sign next to it. Hovering over 
the yellow icon will display a tooltip explaining what the difference is. 

Page 257ScreenSteps 2.9



How do I Download a Manual from 
ScreenSteps Live to my ScreenSteps Desktop 
Library? 

This lesson will show you how to download a manual from ScreenSteps Live, complete with 
all of its package files, to your ScreenSteps Desktop software. Once the manual is 
downloaded you will be able to edit the lessons and repost them. 

IMPORTANT: In order to download lessons in a manual, the packages must have been 
uploaded to ScreenSteps Live. 

Select File > Import From ScreenSteps Live > Manual 

Page 258ScreenSteps 2.9



Select Manual and Download 

Select the manual you wish to download and select OK. The manual will be downloaded and 
imported. 
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How do I Update a Lesson on ScreenSteps 
Desktop From ScreenSteps Live? 

Open Lesson and Inspect 

Open the lesson and select the Inspect icon. 

Update Lesson From Server 

1. Select the Web tab. 

2. Select the account where the lesson was uploaded. 

3. Select Update Lesson From Server. 

Your local lesson will be replaced with the one from the server. 
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How do I Replace a Lesson on ScreenSteps 
Live? 

This lesson will teach you how to replace or update a lesson that already exists on your 
ScreenSteps Live account. 

Select ScreenSteps Live 

Open the lesson you wish to upload and select Export > ScreenSteps Live. 
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Updating a Lesson 

If you have already uploaded this lesson to your ScreenSteps Live account you will be given the 
option to Update lesson.  Selecting upload will replace the contents of the lesson on the server 
with the contents of your lesson on your local computer. 

How does ScreenSteps know which lesson to replace? When you upload a lesson to 
ScreenSteps Live an ID is created for that lesson in your ScreenSteps Live account.  Your 
ScreenSteps Desktop stores that id after it uploads the lesson.  When you post the lesson again 
ScreenSteps Desktop asks ScreenSteps Live if there is a lesson with the same ID on the server 
and will update that lesson. 

This lesson will teach you how to replace or update a lesson that already exists on your 
ScreenSteps Live account. 
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Select ScreenSteps Live 

Open the lesson you wish to upload and select Export > ScreenSteps Live. 
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Updating a Lesson 

If you have already uploaded this lesson to your ScreenSteps Live account you will be given the 
option to Update lesson.  Selecting upload will replace the contents of the lesson on the server 
with the contents of your lesson on your local computer. 

How does ScreenSteps know which lesson to replace? When you upload a lesson to 
ScreenSteps Live an ID is created for that lesson in your ScreenSteps Live account.  Your 
ScreenSteps Desktop stores that id after it uploads the lesson.  When you post the lesson again 
ScreenSteps Desktop asks ScreenSteps Live if there is a lesson with the same ID on the server 
and will update that lesson. 
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How do I Upload a Lesson Directly to a 
Manual? 

You can add a single lesson directly to a manual when you first upload it to ScreenSteps 
Live. 

Note: If you want to move a lesson into a manual that has already been uploaded to 
ScreenSteps Live then follow these instructions. 

Link Lesson to Manual 

From the lesson upload screen select Link Lesson to: Manual (1). Then choose the manual (2) 
and the chapter you want to add it to (3). The lesson will be added to the end of the chapter. 
You can reorder lessons in the chapter from the web interface. 

A better way to do this is often to create the lesson in the chapter on your desktop and then 
upload that chapter. 
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How do I Download a Lesson to My 
ScreenSteps Library From ScreenSteps Live? 

All editing of lesson content is done in the ScreenSteps Desktop software. 

If the lesson is already in your lesson library then you can just re-upload it. If it is not then 
follow the directions below to download the lesson into your library. 

Download the Lesson 

If you don't already have the lesson in your ScreenSteps Desktop software then download the 
lesson package. Select File > Import From ScreenSteps Live > Lesson. 
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Select Lesson and Import 

Select the lesson you want to import (1) and select OK (2). 

The lesson will be imported into your desktop software. You can then edit the lesson and re-
upload it to your ScreenSteps Live account. 
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Confirming that a manual is linked to 
ScreenSteps Live 

Open Manual Inspector 
1. Select your manual 
2. Select Inspect 

Web Inspector 
Select the Web tab in the inspector. If an entry appears then your manual is linked to 
ScreenSteps Live. If one does not appear then the manual is not connected to ScreenSteps Live. 

You can break the link by selecting the entry and pressing delete on your keyboard. 
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Updating a manual on ScreenSteps Live with 
changes from ScreenSteps Desktop 

This lesson will show you how to upload to ScreenSteps Live all the changes you have made 
to your manual in ScreenSteps Desktop. 

Export Manual 

Select the manual (1) and then select Export > ScreenSteps Live (2, 3). 

Page 270ScreenSteps 2.9



Select Upload 

ScreenSteps knows that you have uploaded this manual to ScreenSteps Live before. Just choose 
your options and select Upload. 
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Preview Changes and Select Upload 

The changes that will be made to your manual on ScreenSteps Live will be displayed in a list. If 
you want to continue with the upload select Upload. 

Page 272ScreenSteps 2.9



How to download changes to a single 
chapter from ScreenSteps Live 

Select Download Changes 

If a chapter has been uploaded to ScreenSteps Live you will see a globe icon next to the chapter 
(1). Clicking on the icon will display a menu. Select Download Changes from ScreenSteps Live. 

You will be notified of any changes that will be made to your chapter before you download. If 
you want to accept the changes, select Download Updates. 
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Uploading a Single Chapter to ScreenSteps 
Live From ScreenSteps Desktop 

This lesson will show you how to upload one chapter at a time to ScreenSteps Live. 

Select the ScreenSteps Live Icon For the Chapter 

Choose Upload to ScreenSteps Live 

If you have multiple ScreenSteps Live accounts you will also choose the account you wish to 
upload to. 
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How do I send a link to an article? 

Space URLs vs. Administration URLs 
There are various ways that you can get the urls for lessons that you have posted to 
ScreenSteps Live. It is important that you keep clear the difference between space urls and 
admin urls. 

Use a space url if you want to send a link to a customer or user. 

Use an admin url if you want to send a link to another author or administrator on your account. 

Getting the URL Right After Upload 

Right after you upload a lesson you will see a dialog that looks like this. Here you can go directly 
to a lesson or copy the url to your clipboard. 

1. This is the Administration url. Only Admins or Authors on your account will be able to access 
this. 

2. If you have placed the lesson in a manual that is in a Space then you will see the space URLs. 
In this example this lesson is in the ScreenSteps 2.6 manual in the ScreenSteps space. 

3. Clicking the Edit button will take you to the Admin page for the uploaded lesson. 

4. Clicking the Space button will take you to the lesson page in the corresponding space. This is 
where you should send your customers/users. 
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5. Clicking the clipboard icons will copy the corresponding urls to the system clipboard, allowing 
you to easily insert them into an email or instant message. 

Getting the URL Later 

If you need to get the url later, open the lesson and select Inspect. 

Get URLs 

1. Select the Web tab. 

2. Select the account where the lesson was uploaded. 

You will now see all of the urls for that lesson. 
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Breaking a Link Between Your Desktop 
Manual and the One on ScreenSteps Live 

Open Manual Inspector 
1. Select the Manual 
2. Select Inspect 
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Breaking a Link Between a Lesson and a Web Server 

1. Select the Web tab 
2. Select the server 
3. Press the Delete or Backspace key. 

Confirm 

You will be shown a dialog asking you whether or not you want to break the link. Click the 
Break Link button to break the link. The next time you export the manual to ScreenSteps Live a 
new manual will be created. 
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What Happens if Multiple People Edit the 
Same Lesson? 

This lesson will give you an idea of how manual syncing works with ScreenSteps 2.9. It is 
important to understand that ScreenSteps Live currently syncs lessons as a whole. It will 
not merge changes to individual steps in a lesson. Think of it as syncing the table of 
contents in the manual and not the individual contents of a lesson or tutorial. 

If you are using ScreenSteps 3, this article does not apply to you. 

Lesson is Posted 

In this example we have two users, Person A and Person B. Person A posts a lesson in a manual 
to ScreenSteps. 
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Person B Downloads Lesson 

Person B then downloads the package file for the lesson to their desktop software. 

All Lessons are the same 

At this point the lesson content is exactly the same between ScreenSteps, Person A and Person 
B. 
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Person A Makes Changes and Uploads 

Now Person A updates the lesson and posts the changes to ScreenSteps. 

Lessons Out of Sync 

We now have an issue where the lessons are out of sync. Person B's local copy of the lesson 
does not match what is on ScreenSteps. 
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We Recommend Person B Sync Down 

We recommend that when working on lessons that are being synced to a ScreenSteps account 
that you perform a downward sync before you begin. This will ensure that you are always using 
the latest content. See this lesson to learn how to do a downward sync. 

What Happens if Person B Tries to Overwrite? 

If Person B does not sync before updating the lesson their local copy will overwrite the lesson 
on the ScreenSteps site once they try to post. 
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Upgrading to 2.8.2 or later - Uploading 
Unique Lessons Identifiers to ScreenSteps 
Live 

A Little Background (You Can Skip This If You Want) 
With the release of ScreenSteps 2.8 we introduced the ability to link between two lessons in a 
manual while working in ScreenSteps Desktop. To do this, ScreenSteps would store a reference 
to the lesson being linked to and would resolve the link to the lesson when you exported the 
manual (e.g. to Word or ScreenSteps Live). 

The initial 2.8 release relied on a lesson identifier that was only unique to each ScreenSteps 
library. What this meant is that when you shared your manual authoring materials with other 
ScreenSteps users the links to lessons within manuals would most likely break. 

With version 2.8.2 we have introduced a universally unique lesson identifier that is used when 
linking between lessons. When you open a ScreenSteps Library for the first time in 2.8.2 this 
identifier is automatically generated and all of your links between lessons are updated to use 
the new identifier. 

ScreenSteps Live users need to perform some extra steps, though, as the lesson source 
materials stored on the ScreenSteps Live server will not contain the new unique identifier. One 
of the manual authors needs to update that source material so that other users working on the 
manual can then download updated lessons with the correct unique identifier. 

This lesson will show you how to perform this update. 

If you have any questions at all or just want someone to hold your hand while going through 
these steps please contact support. 

Updating Source Material on ScreenSteps Live (You Can't 
Skip This Part) 

Step 1) Upgrade All Users to ScreenSteps 2.8.2 or later 
You should upgrade all users in your organization to ScreenSteps 2.8.2 or later. Otherwise the 
lesson unique identifiers will be lost when downloading content from or uploading content to 
ScreenSteps Live. 
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Step 2) Break Link Between Manual and Server 

IMPORTANT: The following instructions will change the urls of the chapters in your manuals 
(not the lessons though). If you have published public links to individual chapters in your 
manual then you can do 1 of 2 things: 

1) Use the Redirect feature in ScreenSteps Live to point the old links to the new chapters. This is 
the easiest solution. 

2) DO NOT replace the manual on the server. You should upload each lesson individually by 
right-clicking on it and selecting Export > ScreenSteps Live from the contextual menu. 

Now that everyone has 2.8.2 or later installed you need to republish your manuals to 
ScreenSteps Live. This will upload all of the manual lessons along with their unique identifiers. 
Open the ScreenSteps Library that contains the entire manual. 

In the inspector palette web palette select the ScreenSteps Live account the manual is 
associated with. 

Press the delete or backspace key to break the link between the manual and the account. 

Confirm that you want to break the link in the dialog that appears. 
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Export to ScreenSteps Live 
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Step 3) Replace Manual on Server 

From the export dialog that appears you want to REPLACE the same manual on the server (1). 
Doing so forces ScreenSteps to upload all source material again. 

Since I'm uploading the Creating Word Templates manual I select Creating Word Templates 
from the replace menu (2). 

Configure any other settings that apply (3). 

Press Upload (4). 

ScreenSteps will upload all content to the ScreenSteps Live server. Note that my manual will be 
unavailable while the lessons are uploaded. 

Other authors can now import the manual into their ScreenSteps Desktop software by following 
these instructions. 
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Upgrading to 2.8.2 or later - Downloading 
Unique Lesson Identifiers From ScreenSteps 
Live to Other Computers 

Step 1) Delete Manual 

To import the updated manual materials from ScreenSteps Live, open a ScreenSteps Desktop 
library. If the manual already exists in the library on the desktop then right-click on the manual 
and select Delete. 

In this example I am deleting the manual Creating Word Templates. 

IMPORTANT: If you have any lessons in the manual that have not been uploaded to 
ScreenSteps Live then you should REMOVE them from the manual before you delete the 
manual. You can then add the lessons back into the manual after you finish following these 
steps. 
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Step 2) Delete Lessons 

In the dialog that appears you can check a box that will delete all manual lessons from the 
library. Check this box so that you don't end up with duplicate lessons in your library. 

NOTE: If the manual shares lessons with other lessons in your manual then please contact 
support and we can help you deal with this situation smoothly. 

Step 3) Import Manual 

Now you can import the manual from ScreenSteps Live. Select File > Import From 
ScreenSteps Live > Manual. 
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In the dialog that appears select the manual you would like to import. I'm going to import 
Creating Word Templates. 

The import dialog will display while the manual is imported. 
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The Result 

The manual will now appear in your library and the lessons will have the same unique 
identifiers as the lessons on ScreenSteps Live. 
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Errors uploading a lesson or manual 

We occasionally have users who see this error when uploading lessons to ScreenSteps Live. The 
error message will be something like: 

"A problem occurred while uploading the lesson: uploading lesson (No action responded to...)" 

This is caused by a bug in a form parsing library that we use. This occurs when the lesson you 
upload to ScreenSteps matches an exact length. The parsing library will throw an error and you 
will see this message. 

How to fix it 
The fix is fairly simple, All you need to do is add a single space at the end of your lesson 
description or the instructional text of your first step. Once you do that it changes the length of 
the lesson and you should be able to upload again. 

How to find which lesson is causing the problem 

If you are just uploading an individual lesson then tracking down the problem is pretty straight 
forward. But if you are uploading many lessons in a manual it can be tricky to find out which 
one is causing the problem. 
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One clue is the lesson id that is highlighted in the message above. This is the id of the lesson on 
ScreenSteps. If you go to your account url and go to the path /admin/lessons/{the_lesson_id} 
then you will see which lesson is having the issue. So, in this example I would go to 
http://example.screenstepslive.com/admin/lessons/38166. 

If that seems too confusing then just shoot us an email and we can tell what lesson is causing 
the issue. 
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